aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLuca Deri <deri@ntop.org>2022-02-28 15:18:10 +0100
committerLuca Deri <deri@ntop.org>2022-02-28 15:18:10 +0100
commit1a8a6aa161eded7367b29462d6e7de955e760d7d (patch)
tree57f2f451e914741d93d6de8e65b0455ca56510c1 /configure.ac
parente193f3713de57a738aae735101f20ff78bd23e8c (diff)
Unless --with-libgcrypt is used, nDPI now uses its internal gcrypt implementation
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 462847387..0040b0b8c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -16,6 +16,7 @@ AS_IF([test "${with_only_libndpi+set}" = set],[
AC_ARG_WITH(sanitizer, AS_HELP_STRING([--with-sanitizer], [Build with support for address, undefined and leak sanitizer]))
AC_ARG_ENABLE(fuzztargets, AS_HELP_STRING([--enable-fuzztargets], [Enable fuzz targets]),[enable_fuzztargets=$enableval],[enable_fuzztargets=no])
AC_ARG_ENABLE(code-coverage, AS_HELP_STRING([--enable-code-coverage], [Generate Code Coverage report]))
+AC_ARG_WITH(libgcrypt, AS_HELP_STRING([--with-libgcrypt], [Build with libgcritp (if prsent) instead of the enclosed gcryt light]))
AS_IF([test "x$enable_fuzztargets" = "xyes"], [BUILD_FUZZTARGETS=1], [BUILD_FUZZTARGETS=0])
AM_CONDITIONAL([BUILD_FUZZTARGETS], [test "x$enable_fuzztargets" = "xyes"])
@@ -237,6 +238,7 @@ AM_CONDITIONAL([HAS_FUZZLDFLAGS], [test "x$has_sanitizefuzzer" = "xyes"])
AC_CHECK_LIB(pthread, pthread_setaffinity_np, AC_DEFINE_UNQUOTED(HAVE_PTHREAD_SETAFFINITY_NP, 1, [libc has pthread_setaffinity_np]))
+AS_IF([test "${with_libgcrypt+set}" = set],[
dnl> GCRYPT
GCRYPT_ENABLED=1
AC_ARG_ENABLE([gcrypt],
@@ -257,6 +259,7 @@ AS_IF([test ${GCRYPT_ENABLED} -eq 1], [
fi
fi
])
+])
dnl> PCRE
PCRE_ENABLED=0