aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLuca Deri <deri@ntop.org>2021-12-04 13:21:57 +0100
committerLuca Deri <deri@ntop.org>2021-12-04 13:21:57 +0100
commitfb85dac9059a93078921c23f5983ed6a70453a8e (patch)
treee83bf45605cde609ac64a8606634f5cb4ce9fe02 /configure.ac
parentfe2822c6a8fcbf9e0a4bb9ee7558cbd0c310e067 (diff)
Configure improvements
Fixed invalid anomaly detection in rrd_anomaly
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index f4436d90b..7a6fbab9a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -106,8 +106,14 @@ CFLAGS="-W -Wall -Wno-unused-parameter -Wno-unused-function $CFLAGS $JSONC_CFLAG
AC_CHECK_HEADERS([netinet/in.h stdint.h stdlib.h string.h unistd.h math.h float.h])
AC_CHECK_LIB([m], [sqrt], [], [LIBM="-lm"])
+AC_CHECK_LIB([rrd], [rrd_fetch_r], [LIBRRD=-lrrd])
-ADDITIONAL_LIBS="$LIBM"
+if test "x$ac_cv_lib_rrd_rrd_fetch_r" = xyes; then :
+ AC_DEFINE_UNQUOTED(HAVE_RRDTOOL, "1", [rrdtool is present])
+ EXTRA_TARGETS="rrdtool"
+fi
+
+ADDITIONAL_LIBS="$LIBRRD $LIBM"
PCAP_HOME=$HOME/PF_RING/userland
DPDK_TARGET=