aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorToni <matzeton@googlemail.com>2022-05-07 09:26:09 +0200
committerGitHub <noreply@github.com>2022-05-07 09:26:09 +0200
commit87f93ea4fd86da8bcfd75b7d74b49dce720d8ef6 (patch)
tree23cc9dae2eb4ee0136c731806b85294cae80e28c /configure.ac
parent2e0dedbaae24a8662a494e15fe47a67ea30fdcec (diff)
Replaced ndpiReader's libjson-c support with libnDPI's internal serialization interface. (#1535)
* Fixes #1528 * Serialization Interface should also fuzzed * libjson-c may only be used in the unit test to verify the internal serialization interface * Serialization Interface supports tlv(broken), csv and json * Unit test does work again and requires libjson-c Signed-off-by: lns <matzeton@googlemail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 9a3b0da7f..c892e0cbf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -99,7 +99,11 @@ AC_DEFINE_UNQUOTED(NDPI_GIT_DATE, "${GIT_DATE}", [Last GIT change])
if ! test "${with_only_libndpi+set}" = set; then :
dnl> used by json-c for unit tests
- PKG_CHECK_MODULES([JSONC], [json-c], [JSONC_LIBS="${pkg_cv_JSONC_LIBS}" JSONC_CFLAGS="${pkg_cv_JSONC_CFLAGS}"], [AC_MSG_WARN([JSON-C not available. Disabled unit test.])])
+ PKG_CHECK_MODULES([JSONC], [json-c], [
+ AC_DEFINE(HAVE_LIBJSON_C, 1, [libjson-c is present])
+ JSONC_LIBS="${pkg_cv_JSONC_LIBS}"
+ JSONC_CFLAGS="${pkg_cv_JSONC_CFLAGS}"
+ ], [AC_MSG_WARN([JSON-C not available. Disabled unit test.])])
AC_CHECK_LIB([json-c], [json_object_put], [EXTRA_TARGETS="$EXTRA_TARGETS tests/unit"], [
AC_MSG_WARN([JSON-C not available. Disabled unit test.])
JSONC_LIBS=""