aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorlns <matzeton@googlemail.com>2022-05-30 00:32:31 +0200
committerlns <matzeton@googlemail.com>2022-05-30 19:22:22 +0200
commitfd5fa116f29d76269d90da78b6efa8cb2d6e6c07 (patch)
tree2192065ba2b96d7a93c8e3768093388604ee32f8 /Makefile.am
parent912b69af60ce2408341fa440374195330fe46439 (diff)
* make check great again (not so much) * make doc/doc-view * CI updates Signed-off-by: lns <matzeton@googlemail.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index fe9ccc27c..463c043c3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -21,5 +21,12 @@ EXTRA_DIST = README.md README.nDPI README.fuzzer.md CHANGELOG.md CONTRIBUTING.md
sonar-project.properties .github .ci-ignore .lgtm/cpp-queries/packet-payload-integer-arithmetic.ql lgtm.yml
+.PHONY: doc doc-view
+doc:
+ make -C doc html
+
+doc-view:
+ python3 -m http.server --bind 127.0.0.1 --directory doc/_build/html 8080
+
changelog:
git log --since={`curl -s https://github.com/ntop/ndpi/releases | grep datetime | head -n1 | egrep -o "[0-9]+\-[0-9]+\-[0-9]+"`} --name-only --pretty=format:" - %s" | grep "^ " > CHANGELOG.latest